Logo Four Seasons Hosting Status Page

Upstream Outage

  • Identified
    Our Upstream is saying with in the hour all upstream connections issues should be fixed
  • Investigating
    We're aware all game servers are down, We are working on this with the upstream now